ICSE Java Complete Reference book is currently available as print on demand and can be bought from online stores. Please check the discounts offered by different websites. second edition of book (2013 release) includes 2013 board paper solution.
Additionally: Complimentary shipping for 25+ copies in a single order to a single address within India.
Good news!!
Discount is offered on 25+ copies. For more details write to info@pothi.com
Additionally: Complimentary shipping for 25+ copies in a single order to a single address within India.
Note: No further negotiation in terms of discount will be possible with Pothi.com as discounts are standard.
1. Pothi.com:
2. infibeam :
3. flipkart :
4. homeshop18 :
5. Amazon India :
6. dial a book :
ICSE Paper – 2013
Class – X
Subject – Computer Applications
Class – X
Subject – Computer Applications
(Class:
X)
(Two Hours)
Answer to this paper must be written on the paper
provided separately.
This paper is divided into two sections.
Attempt ALL questions from Section
A and any FOUR questions from Section B.
The intended marks for questions or parts of
questions are given in brackets [ ].
SECTION A (40 Marks)
Attempt ALL questions.
Q1.a) What is meant by precedence of operators? [2x5=10]
b) What
is a literal?
c) State
the Java concept that is implemented through:
i)
a super class and a subclass.
ii) the act of representing essential features
without including
background details.
d) Give
a difference between constructor and method.
e) What
are the types of casting shown by the following examples?
i) double x =15.2;
int y =(int) x;
ii) int x =12;
long y = x;
Q2.a) Name
any two wrapper classes. [2x5=10]
b) What is the difference
between break and continue statements
when they occur in a loop.
c) Write statements to show how finding
the length of a character
array and char[] differs from
finding the length of a String object str.
d) Name the Java keyword that:
(i) indicates a method has no return type.
(ii) stores the address of the
currently calling object.
e) What is an exception?
Q3.a) Write
Java statement to create an object mp4 of class digital. [2x10=20]
b) State the values stored in variables str1
and str2
String
s1 = “good”; String s2=”world matters”;
String str1 =
s2.substring(5).replace(‘t’,’n’);
String
str2 = s1.concat(str1);
c) What does a class
encapsulate?
d) Rewrite the following program segment using
the if..else statement.
comm
=(sale>15000)?sale*5/100:0;
e) How many times will the following loop
execute?
What value will be returned?
int x = 2,
y = 50;
do{
++x;
y-=x++;
}while(x<=10);
return y;
f) What
is the data type that the following library functions return?
i)
isWhitespace(char ch)
ii) Math.random()
g) Write a Java expression
for ut + ½ ft2
h) If int n[] ={1, 2, 3, 5,
7, 9, 13, 16} what are the values of x and y?
x=Math.pow(n[4],n[2]);
y=Math.sqrt(n[5]+[7]);
i) What is the final value of ctr after the
iteration process given below, executes?
int
ctr=0;
for(int i=1;i<=5;i++)
for(int
j=1;j<=5;j+=2)
++ctr;
j) Name the methods of Scanner class that:
i) is used to input an integer data from
standard input stream.
ii) is used to input a string data from standard
input stream.
SECTION B (60 Marks )
Attempt any four questions from
this Section.
The answers in this section should consist of the program
in Blue J environment with Java as the base. Each program should be written
using Variable descriptions / Mnemonics Codes such that the
logic of the program is clearly depicted.
Flow-charts and Algorithms are not required.
Q4. Define a
class called FruitJuice with the following description: [15]
Instance variables/data members:
int product_code - stores the product code number
String flavour - stores the flavor of the juice.(orange, apple, etc)
String pack_type - stores the type of packaging (tetra-pack,
bottle etc)
int pack_size - stores package size (200ml, 400ml etc)
int product_price - stores the price of the product
Member Methods:
FriuitJuice() - default constructor to initialize integer data members
to zero and
string data members to “”.
void input() - to input and store the product code, flavor, pack type,
pack size and product
price.
void discount() - to reduce the product price by 10.
void display() - to display the product code, flavor, pack type,
pack size and product
price.
Q5. The
International Standard Book Number (ISBN) is a unique numeric book identifier
which is printed on every book. The ISBN is based upon a 10-digit code. The
ISBN is legal if:
1xdigit1 +
2xdigit2 + 3xdigit3 + 4xdigit4 + 5xdigit5 + 6xdigit6 + 7xdigit7 + 8xdigit8 +
9xdigit9 + 10xdigit10 is divisible by 11.
Example: For an ISBN 1401601499
Sum=1x1 + 2x4 +
3x0 + 4x1 + 5x6 + 6x0 + 7x1 + 8x4 + 9x9 + 10x9 = 253 which is divisible by 11.
Write a program
to:
(i) input the ISBN
code as a 10-digit integer.
(ii) If the
ISBN is not a 10-digit integer, output the message “Illegal ISBN” and terminate
the program.
(iii) If the
number is 10-digit, extract the digits of the number and compute the sum as
explained above.
If the sum is
divisible by 11, output the message, “Legal ISBN”. If the sum is not divisible
by 11, output the message, “Illegal ISBN”. [15]
Q6. Write a
program that encodes a word into Piglatin. To translate word into Piglatin
word, convert the word into uppercase and then place the first vowel of the
original word as the start of the new word along with the remaining alphabets.
The alphabets present before the vowel being shifted towards the end followed
by “AY”.
Sample Input(1):
London Sample Output(1): ONDONLAY
Sample Input(2):
Olympics Sample Output(2): OLYMPICSAY [15]
Q7. Write a
program to input 10 integer elements in an array and sort them
In descending order using bubble sort
technique. [15]
Q8. Design a
class to overload a function series() as follows: [15]
(i) double
series(double n) with one double argument and
returns the sum of the series.
sum
= 1/1 + 1/2 + 1/3 + ….. 1/n
(ii) double
series(double a, double n) with two double arguments
and returns the sum of the series.
sum = 1/a2 + 4/a5 + 7/a8 + 10/a11 ….. to n
terms
Q9. Using the
switch statement, write a menu driven program: [15]
(i) To check
and display whether a number input by the user is
a composite number or not (A number is
said to be a composite, if it
has one or more then one factors excluding
1 and the number itself).
Example:
4, 6, 8, 9…
(ii) To find
the smallest digit of an integer that is input:
Sample input: 6524
Sample output: Smallest digit is 2
For an
incorrect choice, an appropriate error message should be displayed.